Search found 83 matches

by PhilHornby
31 Oct 2017, 15:05
Forum: Netatmo API
Topic: Thermostat: status of boiler (ON or OFF) in realtime
Replies: 2
Views: 389

Re: Thermostat: status of boiler (ON or OFF) in realtime

/api.netatmo.com/api/getthermostatsdata returns " therm_relay_cmd " in the {devices} section. For my relay, at least, this has a value of " 0 " for OFF and " 100 " for ON. I don't know if this is documented anywhere. The fact that the " ON " value is not a " 1 " might mean it is bit-encoded to say ...
by PhilHornby
27 Oct 2017, 20:47
Forum: Thermostat Network Set-up
Topic: Maximum distance between thermostat and relay
Replies: 3
Views: 431

Re: Maximum distance between thermostat and relay

Probably wise - customer service *never* answer....
by PhilHornby
22 Oct 2017, 14:30
Forum: Thermostat Network Set-up
Topic: WI FI Config DNS Problem
Replies: 2
Views: 366

Re: WI FI Config DNS Problem

It shows up as "NetatmoRelay" on my router - which may, or may not, be the answer to your question :|
by PhilHornby
13 Sep 2017, 18:58
Forum: Netatmo API
Topic: getthermostatsdata only updated every hour / Web UI
Replies: 3
Views: 420

Re: getthermostatsdata only updated every hour / Web UI

There is an (undocumented?) API call: 'syncthermstate' that the Web interface uses. (Requires access_token and device_id). There's probably no point in calling it too frequently; the thermostat ain't that responsive! If netatmo don't want the load on their servers, they could always provide a local ...
by PhilHornby
22 Aug 2017, 00:40
Forum: Netatmo API
Topic: invalid_grant
Replies: 5
Views: 537

Re: invalid_grant

I do have a redirect URI = but it points to a 404 error ;-)
Webhook is blank
App website is a valid URL - but nothing to do with the app ;-)
Company is "ACME Dodge Software Inc." ;-)
Company website is the same as App website - valid, but irrelevant ;-)
by PhilHornby
20 Aug 2017, 20:45
Forum: Netatmo API
Topic: invalid_grant
Replies: 5
Views: 537

Re: invalid_grant

I'm not overly familiar with JavaScript, but I think the format of the data you are sending to the API is not quite correct? I can't see the "&" character between parameters (but maybe some .JS function adds those automatically). Compared with what I send (which works), you seem to have a lot of "qu...
by PhilHornby
11 Aug 2017, 03:18
Forum: Netatmo API
Topic: api.netatmo.com Down?
Replies: 68
Views: 6151

Re: api.netatmo.com Down?

If you have a means to change the IP address you're using, try that.

I have two fixed IP addresses at my disposal - the API responds to neither of them :cry: . If I tether to my mobile phone, it works fine! :roll:
by PhilHornby
09 Aug 2017, 19:05
Forum: Netatmo API
Topic: api.netatmo.com Down?
Replies: 68
Views: 6151

Re: api.netatmo.com Down?

You might be 'firewalled' ... like I am.

I've seen it before - the API just plays dead and refuses to connect, unless you change IP address (by whatever means). I don't know how long it lasts, because - guess what - Netatmo never responded when I asked them :-(
by PhilHornby
09 Feb 2017, 18:20
Forum: Thermostat Network Set-up
Topic: Netatmo Relay keeps disconnecting from servers
Replies: 226
Views: 11301

Re: Netatmo Relay keeps disconnecting from servers

Did you tried to change the wifi channel, using channel 1, 6 or 11? Let me and all the forum know if changing the wifi channels makes some difference so we can understand if the issue is actually related to the wifi component of the relay. Channel 1 doesn't work for me ... if it connects at all, th...

Go to advanced search