Support / main module gone bad

This forum provides technical help on how to set up Netatmo Weather Stations for the first time.
Post Reply
LuftikusA380
Posts: 9
Joined: 26 Jan 2014, 21:32

Support / main module gone bad

Post by LuftikusA380 » 04 May 2015, 19:54

Hi guys,

I just would like to share my disappointment with Netatmo...

A couple of days ago, the temperature readout of my main module went crazy, constantly showing around 27 degrees (+ - a couple .1 degrees). I placed my second indoor module just next to the main module, and the "real" temperature was 22-23 degrees, thus the main module shows 4-5 degrees more than the actual temperature. CO2 readout seems to be to affected, too, as it constantly shows a higher CO2 value than the other module.
I tried to update the FW of my modules, but when I connect the main module to the USB port of my Mac, it is not recognized by the NetatmoWizard. I tried different ports, and even another computer: No help. The thing seems totally fu#*@$ up :evil:

So I contacted support, and today I received the answer, which does not satisfy me at all:
- Warranty has expired, so no exchange is possible. I bought the station in mid December 2012, so it barely lasted 2 1/2 years. Wow, I am impressed - well, given the fact that I paid 169 EUR for the unit (minus x % from a coupon...), not really, actually. :evil:
- Hint from support was, that I could calibrate the temperature module to have the true readout. Ok, I figured that out, but how do I know the offset?! And is the offset a constant value through all temperature ranges...? This can't seriously be the solution to my problem, can it? For THIS price Netatmo is asking?
- Last thing support offered was a 10% discount coupon, in case I wanted to buy an new unit. I made clear in my support request, that buying a new station was not an option! It is 2 1/2 years old!!! There are no moving parts, it is a weather station. What on earth can fu#% up a simple temperature module?!

I am pretty disappointed with the answer I received, I was not offered useful help at all. Response time was awesome, I must give them that.

Isn't there any way to have the module repaired, if I am not entitled to an exchange? I mean, come on... 169 EUR down the drain? I can't believe it! The only thing I am glad about is, that I "only" bought 1 additional indoor module and not the rain or wind gauge on top.

Sorry to say, Netatmo: Lousy service! J'avais espéré mieux, je suis très déçu.

LuftikusA380
Posts: 9
Joined: 26 Jan 2014, 21:32

Re: Support / main module gone bad

Post by LuftikusA380 » 12 May 2015, 15:28

Status update: Today, I received an email offering to repair the module for a reasonable price - shipping & handling is on me. I'll go for it.

That's the way I understand support / customer service should be...

Post Reply

Return to “Setting up my Weather Station”