advance/anticipation calculation fails

Tips, tricks and frequently asked questions
Alex79
Posts: 7
Joined: 27 Jan 2016, 10:10

Re: advance/anticipation calculation fails

Post by Alex79 » 11 Dec 2018, 08:12

cesco wrote:Same trick didn't work this morning, but I touched the schedule just before going to bed, that means 6-7 hours before the heating turns on. For me it's the contrary, in the morning it never gets it right and it starts 30 minutes before for one entire week now
thanks for sharing your experience, I think 6-7 hours ahead is too early, but this can't be a fix anyway, someone should seriously look into this and find a solution.
4th winter with Netamo and every season there's something strange or not working I have to report.
Customer service needs some serious improvement too, every year reply times gets longer and longer.
All in all I would say, this is a fantastic product, only WHEN it works, and forget about customer service.

cesco
Posts: 33
Joined: 04 Dec 2018, 14:00

Re: advance/anticipation calculation fails

Post by cesco » 11 Dec 2018, 08:54

I must say this is the first time I needed to contact support from February 2014 when I bought the Thermostat (I already owned the Weather Station). This Thermostat is a fantastic product for sure. Yes, maybe support answer can definitely improve, but I can imagine that during winter they are overwhelmed by support requests, being thermostat and valves very popular by now.

I hope they can better pinpoint the problem with our experiences reported here. I think a VERY small percentage of users know the existence of this forum, so it's difficult to perceive if the problem is widely spread or it's only a few cases.

Have a good and warm day :-D

Brieuc_Netatmo
Posts: 2892
Joined: 02 Jan 2014, 11:20

Re: advance/anticipation calculation fails

Post by Brieuc_Netatmo » 11 Dec 2018, 09:07

Hi,
Please let us know the serial number of your Relay to allow us to investigate on this issue.
In the meantime, make sure your Wi-Fi connection is reliable.
Brieuc - Netatmo Team

cesco
Posts: 33
Joined: 04 Dec 2018, 14:00

Re: advance/anticipation calculation fails

Post by cesco » 11 Dec 2018, 09:19

Hello Brieuc.

I just answered to Alessandra from Netatmo Support. As I said to her I'm at the office right now and I'm monitoring my thermostat on a page always open and I see no disconnection at all. I also sent her a screenshot taken a minute ago showing that I can reach the Thermostat from the office with no problem at all. WiFi and radio signal are pretty good and both Thermostat and Relay are in the same position for almost 5 years now.

Relay: g074aa2 (FW 176)
Thermostat: j073fc2 (FW 65)
2018-12-11_091823.png
2018-12-11_091823.png (3.92 KiB) Viewed 197 times
Thanks again.

Alex79
Posts: 7
Joined: 27 Jan 2016, 10:10

Re: advance/anticipation calculation fails

Post by Alex79 » 11 Dec 2018, 09:22

Brieuc_Netatmo wrote:Hi,
Please let us know the serial number of your Relay to allow us to investigate on this issue.
In the meantime, make sure your Wi-Fi connection is reliable.
Hello

relais serial no. g0a03d0
Wi-Fi is reliable
thanks for looking into this.
A ticket was opened few days ago concerning this issue. (no reply as yet)

Alexandre_Netatmo
Posts: 457
Joined: 13 Jul 2017, 10:42

Re: advance/anticipation calculation fails

Post by Alexandre_Netatmo » 11 Dec 2018, 11:20

Hey,
We are investigating to see if something happened.
To help us can you please tell us exactly when it should have anticipated more than 30 min and it did not.
Exemple : 11/12/2018 , planning 20° at 8h00 , usually the boiler turns ON around 06h30 but only turned ON at 07h30.

Just so you know , for anticipation we need the external temperature either from your weather station or from the weather forecast:
Either your Relay lost wifi connection with the internet box => could not retrieve the external temperature => 30 min default anticipation
or there is something on our weather forecast provider.

Alexandre

cesco
Posts: 33
Joined: 04 Dec 2018, 14:00

Re: advance/anticipation calculation fails

Post by cesco » 11 Dec 2018, 11:45

Hello Alexandre.

My problem started 10 days ago, but started appearing regularly from Monday 3rd December in the afternoon. I activated the AWAY option with a scheduled comeback and it switched back on 30 minutes default. From there every single change in temperature has been wrong, apart from 3 exceptions.

So my actual schedule ha 3 changes every day: 7.00 am, 15.00 pm, 20.30 pm. From Monday the 3rd of December in the afternoon every single change has been anticipated by the default 30 minutes, today included.

Only 3 exceptions:
Thursday 6th December the 15.00 pm change has been anticipated at 14.05
Saturday 8th December the 20.30 pm change has been anticipated at 19.50
Yesterday 10th December the 20.30 pm change has been anticipated at 19.33 because I tried messing with the schedule just before the change as Alex told me in the post above. Maybe I did the same for the other two cases above but now I can't remember.

From Monday the 3rd I'm monitoring my Thermostat almost all day long (I work in front of a PC with 4 monitors, so I can always keep one with the Netatmo page in front of me) and I've only seen one 5 minutes disconnection just before the correct anticipation on Thursday. As I wrote before, I really doubt there is a WiFi problem, because the Thermostat is in the same position for 5 years now and I never experienced any problem with it till now. WiFi has not had major changes in years too. I'm pretty picky about computers and networking in my house since I work as a systems engineer and I always try to keep everything working smoothly as much as possible.

Last week I also switched to local meteo for two days for temperature source to rule out the Weather Station as a problem, but nothing changed. Now my external source is back to Netatmo Weather Station.

Thanks again for your support.

Alexandre_Netatmo
Posts: 457
Joined: 13 Jul 2017, 10:42

Re: advance/anticipation calculation fails

Post by Alexandre_Netatmo » 11 Dec 2018, 11:58

Well,
Reading your message I might got something.

If you keep an application open Web/iOS/Android , it prevents your device from getting the external temperature to allow you to anticipate.

I would suggest to not keep an application open and everything should be back to normal.
If it is not, come back to us (on our side we will work on a way to still provide the external temperature even if apps are open all day).

My guess is for some reasons we did not succeed to provide you the external temperature once (could be due too a firmware update , a small wifi disconnection ) ; and from that point you kept monitoring with having an app open all day that prevented your device to anticipate more than 30 min ( but you did not know that , we didn't wrote about it either and we should not , it should be transparent for you)

cesco
Posts: 33
Joined: 04 Dec 2018, 14:00

Re: advance/anticipation calculation fails

Post by cesco » 11 Dec 2018, 12:22

Ok I can try that, but what about the failed morning anticipation at 7.00 am when everything is turned off on my computers and smartphone? Sometimes I leave my Mac turned on during the night but most of the time with browsers and everything else turned off, just to make some backup during the night on Time Machine.

I kept the monitoring open more than usual lately because I noticed something wrong, but I'm pretty sure I did it even before the problem appeared, because during the winter its customary for me to keep an eye on the Thermostat from the office and adjust a bit the schedule depending on my and my wife working hours.

Now I closed every Netatmo window on my PC here at the office.

Thanks Alexandre, I'll report back.

cesco
Posts: 33
Joined: 04 Dec 2018, 14:00

Re: advance/anticipation calculation fails

Post by cesco » 12 Dec 2018, 09:15

Hello Alexandre.

I did as you said in your last post and indeed the anticipation worked flawlessly so far. That means 3 changes, yesterday at 15.00 (14.11), yesterday at 20.30 (19.28) and this morning at 7.00 (4.17).

That's weird because I remember keeping the page open last years during winter, but I accept the fact that now it's better not do do it. It will be nice in the future that an open web session by the user doesn't mess with the fetching of meteo data, but I'm sure you'll sort it out. I'll keep it monitored and maybe report back in a few days if problems don't arise before.

In the meantime thank you again for your support, really appreciated.

Post Reply

Return to “General questions”