Page 1 of 1

Unable to change Desired Temp in (web)app

Posted: 05 Feb 2020, 19:45
by rifraf
I have a weird problem. The NETATMO Thermostat seems to be correctly connected to the internet. I can see the same (desired & measured) temps in the (web) app as on the NETATMO thermostat display itself. I can also see that the thermostat e-ink display is changing the temp to 12 and to 7° C when switching to the AWAY or FROST GUARD MODE from the webapp, the ios app and the android app. The only thing I can't do from any app (web/ios or android) is setting a desired temp myself. There is a (!) icon next to the temp control in the android app. The ios app doesn't have the (!) icon but displays "Cannot connect to Netatmo server" when trying to change the desired temp from the ios app. There's no icon or message in the webapp but it just defaults back to the previous value. I can also NOT edit the custom temps, comfort, comfort+ ... and what is of course most irritating for a thermostat is the fact that it is not following the programmed schedule, the desired temp on the thermostat is always 19°C so it's like the schedule from the (web)app isn't reaching the Thermostat.

Anyone recognizing this problem ? What could be the root cause ? The relay seems to be working, otherwise I wouldn't be able to switch to AWAY or FROST GUARD mode from the apps, that is working fine.

My model = NTH01-EN-EU (3700730500241
Firmware thermostat = 65
Firmware Relay = 176

I have the latest ios/android apps installed.

Thanks in advance

Re: Unable to change Desired Temp in (web)app

Posted: 09 Feb 2020, 23:09
by DW190
Just read your post and wish I could help.

I have a perfectly working thermostat and recommended my friend get one.

Went to set it up for him and am having exactly the same problems as you.

Away and frost setting can be done but nothing else and the android app shows the exclamation mark.

If you manage to solve the issue please let me know, likewise I will post my findings if I manage to sort.

Re: Unable to change Desired Temp in (web)app

Posted: 10 Feb 2020, 12:11
by rifraf
Thanks for sharing.

I tried a few things myself as I wasn't getting any response from Netatmo support after a few days. My last attempt last Thursday was to remove the product (relay) from the webapp. Something I shouldn't have done as I'm completely disconnected and unable to reinstall now ! I can't reinstall because the product (relay) is still associated with an email address (mine). The correct order I believe now is to "uninstall" the relay first and then create a new netatmo account with a new email address. However the uninstall relay menu option is only available when you have a product in the webapp (which I no longer have now). ... sonal-data

The only way out was logging a ticket to completely remove my account, I logged this request last Thursday, still waiting ... ... to-proceed

So the latest status is now awaiting the deletion of my account to start fresh again.

Re: Unable to change Desired Temp in (web)app

Posted: 10 Feb 2020, 21:35
by DW190
Thanks for the very informative response.
Just so I have this clear in my mind. I uninstall the relay via the app, create a new account with a different email address, then reinstall the relay with the new account.

Your mistake was to remove when you should have uninstalled (Is my understanding of what you did correct?)

Wondering if its possible to just reinstall with the same email address after uninstalling.

Thanks again.

Re: Unable to change Desired Temp in (web)app

Posted: 10 Feb 2020, 21:56
by rifraf
Re-using the same account after the uninstall of the relay is worth trying, maybe it does work for you. I'm currently stuck and can not confirm but my reasoning was to start completely fresh.

Meanwhile I got a reply from Netatmo support that it is not needed to delete my account. However their procedure doesn't work for me so I asked again to delete my account as requested.
This is what I got (but it didn't work for me):

You do not need to delete your account to reinstall the product.

Please follow this process:

* Plug the Relay to an AC outlet and wait for the LED to blink 5 times.
* Press the Relay button during approximately 20 seconds, until the LED blinks 5 times again. This will erase all previously stored Wi-Fi and HomeKit settings.
* Uninstall the Energy mobile application, reboot the smartphone or tablet, and install the Energy application again.
* Proceed with the connection of the Relay again, as it was new (

Re: Unable to change Desired Temp in (web)app

Posted: 11 Feb 2020, 06:18
by DW190
Thanks again.

I am at my friends tomorrow to give it another try. Luckily he can control the temperature with the thermostat.

It does sound like a small glitch on the install which hopefully will clear if everything is put back to square one and installed again. I cannot fault mine at home, it even comes on slightly earlier if its colder outside so the desired temp is attained by the set time.

I will report back when Ive had another try.

Re: Unable to change Desired Temp in (web)app

Posted: 12 Feb 2020, 17:42
by DW190
All sorted.

Uninstalled the relay and the app from the phone, rebooted the phone and reset the relay. Removed batteries from thermostat and put back the went through the setup process again starting by disabling the 5.0g on the router.

When at the end of the setup it failed to connect to the wi-fi so hit the retry button and bingo. All up and running. I did not have to set up a new account, it worked fine with the old one.

Thanks again for your input and links, they made life much easier.

Re: Unable to change Desired Temp in (web)app

Posted: 13 Feb 2020, 10:08
by rifraf
Glad to hear that and thanks for sharing !
Fixed here as well without deleting my account. In my case, NETATMO support corrected my corrupt account.
It can take a few days before they come back to you but the support is excellent !! In case you have trouble and can't figure it out yourself, log a ticket and have some patience.

Re: Unable to change Desired Temp in (web)app

Posted: 14 Feb 2020, 01:15
by DW190
Glad your sorted to. I have had mine for twelve months now and am more than pleased with its performance in keeping a constant temp. Also when setting the Away till a given time it comes on before the time and hit the temp by the given time.

Once again, thanks for your input, it saved me the wait using support.