Netatmo Relay keeps disconnecting from servers

This forum provides technical help on how to set up Netatmo Thermostat Wifi connection.
nickfielibert
Posts: 10
Joined: 11 Feb 2016, 14:52

Re: Netatmo Relay keeps disconnecting from servers

Post by nickfielibert » 14 Feb 2016, 21:28

Pete,
It seems we different problems. When my thermostat is disconnected from the netatmo server, it is still responding to pings on my home network en it suffices to reboot the AP to re-establish connection to the netatmo servers. Not knowing how netatmo establishes a connection to the relay, not much more I can do. It could be as you say, the relay initiates this, but based on what?
All in all, I would advise for Netatmo to consider something like XMPP to establish a connecties between server and device, where it could send a message to the relay to send data to the server.

Pete
Posts: 8
Joined: 12 Feb 2016, 19:38

Re: Netatmo Relay keeps disconnecting from servers

Post by Pete » 15 Feb 2016, 20:34

Since setting the wireless channel to 11 from 1 I have not been disconnected. Early days yet but today was the first morning in a while that I have been able to log into the app. I have no idea why this has worked but glad I gave it a try. Lets see if it stays connected and for how long now.

Nick - I agree we do seem to have had differing problems. I did not know this at first but your first post got me thinking that I may have had a problem with DHCP and what I could do to confirm that. In my case I now know DHCP is unlikely to have been the cause of my relay locking up. If my tests had shown the loss of connection was happening at the time of DHCP renewal I was planning on setting up some way of capturing the packets sent by the relay. Then examining them in wireshark to see if I could spot anything wrong in the protocols. I do this as part of my job from time to time so was hoping I could have helped Netatmo find a solution for everybody rather than just set a static IP to work around what I thought to be a DHCP problem.

topazJ
Posts: 3
Joined: 17 Jan 2016, 21:13

Re: Netatmo Relay keeps disconnecting from servers

Post by topazJ » 16 Feb 2016, 12:29

Interesting to read the replies! I have a bit of an IT brain as well so do understand most of what you were discussing.

My thermostat has been stable for about a week but I find that the quickest solution for me is to change the channel number on the router. I also have no idea why it works!

Not much use when I'm away though and want to set the temp when I am on my way back home!

nickfielibert
Posts: 10
Joined: 11 Feb 2016, 14:52

Re: Netatmo Relay keeps disconnecting from servers

Post by nickfielibert » 17 Feb 2016, 12:19

An update:
I´ve r-arranged all frequencies of my AP´s in my home, to essentially non-overlapping bands. Since I did that, I´ve had no more "no connection to netatmo server" problem. It´s 4 days now, so this gives me hope I´m on the right track. I´m still puzzled how interference could cause such problem and why the relay is unaware it lost connection and tries to re.establish the connection. It seems it only does that after a loss of connection to my home gateway, either be rebooting the RGW or by rebooting the AP. Wifi interference only creates packet loss. So, why does simple packet loss close the communication with the server ad leads the relay to not re-establish that? My thinking is this could be very easy to rectify. Because of the home firewall and NAT, only the relay can initiate to connection back to the server, with a simple wait for response from server on regular basis, the relay would be aware of a problem and as such reconnect.
Again, not knowing what protocols are used (wireshark analyses only shows very regular ARP´s between RGW and Netatmo relays, I see Bonjour, assuming this is linked to apple´s home kit and IGMP2 joins from the netatmo relays).

Could Netatmo please react to clarify this???

We´ll see how it goes in the next days.

stefan_g
Posts: 1
Joined: 17 Feb 2016, 23:11

Re: Netatmo Relay keeps disconnecting from servers

Post by stefan_g » 17 Feb 2016, 23:31

Hello guys,

I have the same problem. Netatmo (Pablo) sent me the information, that it is a wlan router problem (unfortunately there is no variety at my german provider Kabeldeutschland. My router type: CBN CH6640E). Therefore I plugged an additional wlan Access Point to my router and switched off the wlan function of the Providers router. It worked for 5 days. Again the same problem.

Poor Support / no response from "Pablo". Then an french mail!?

The thermostat/relay is 350km away (holiday appartment) from my house.

Unacceptable and poor.

Thanks for any additional research and tips!

Best regards,
Stefan.

Brieuc_Netatmo
Posts: 2932
Joined: 02 Jan 2014, 11:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Brieuc_Netatmo » 18 Feb 2016, 09:36

Hello,
Please apologize for late reply, we're doing our best to answer each request as fast as we can.
About your problem, please try to set the Wi-Fi channel of your router to channel 11, it should solve your issue.
Brieuc - Netatmo Team

jmpeces
Posts: 16
Joined: 22 Jan 2016, 17:12

Re: Netatmo Relay keeps disconnecting from servers

Post by jmpeces » 18 Feb 2016, 13:51

It is unfortunate that the only solution is to give Netatmo by users several changes in its router without knowing whether it will work . Clearly, many of us with the same problem and you have to solve the problem you may be you.
One 180 euros spent on a smart thermostat which have to restart 3 times a day ...

nickfielibert
Posts: 10
Joined: 11 Feb 2016, 14:52

Re: Netatmo Relay keeps disconnecting from servers

Post by nickfielibert » 18 Feb 2016, 16:41

Brieuc,
I´m afraid I don´t really agree with you statement that moving to CH11 always is the right solution for the problem. In fact, I´ve tried this, but didn´t make a big difference. It is only after cleaning up the RF spectrum in my home I have something that is now stable for the past 5 days. I don´t know of any WiFi chipset that would have a performance that is frequency dependent, unless there is a HW fault in the chip. I think the reason why people have issues is that the relay see other Wifi networks somehow interfering with the Wifi to which the relay is linked.
Key is that there shouldn´t be a reason for loosing the connection with the server, requiring interaction by the user with the home network (often remote). There are many protocols that could be used, to make the relay aware it has lost connection to the server and to open the communications again. I´ve already mentioned XMPP as one possibility. We are using this for server to device communication and scales to many millions of devices, anywhere in the world. Even with your current set-up it would suffice for the client to reconnect in a fixed time interval. It seems that the relay is unaware it is no longer connected to the server and because it is behind the firewall and NAT, the server has no way to ask the relay to reconnect. Having the client ask for connection every hour would already solve the issue for most users.

Pete
Posts: 8
Joined: 12 Feb 2016, 19:38

Re: Netatmo Relay keeps disconnecting from servers

Post by Pete » 20 Feb 2016, 10:34

Have had a good week since changing the channel to 11 on Sunday.

However this morning I know everything was fine uptp about an hour ago as the boiler was on early in prediction mode - something that can only happen if it can talk to the servers. I noticed about 15 mins ago though that the iOS app on the phone was saying I was disconnected again.

'Tried logging on to the browser based app and this one allowed me in but the readings were a 40 mins behind. If I made a change to the system (e.g. set away mode) the graphic showed syncing continuously as thought it could not see the relay.

I was able to ping the relay this time and also saw the nat rule on the router from the relay to netatmo on port 25050 was established. Signal strength to relay according to access point was "excellent" with speed of 72Mbps and -61dBm.

I reset the access point and this time the relay was able to reconnect to the servers and update the graph without me needing to reboot the relay itself.

I am on firmware ver 57 / 36 so not quite the latest.

nickfielibert
Posts: 10
Joined: 11 Feb 2016, 14:52

Re: Netatmo Relay keeps disconnecting from servers

Post by nickfielibert » 20 Feb 2016, 11:09

Hi Pete,
This proves the CH11 fix proposed by netatmo is not worth a lot. It may simply be there is in general a bit less usage of that channel, so it appears better. My conclusion is that some wifi receivers are a bit more or less sensitive (normal tolerances) an as such some are easier victim to packet loss. The key is that shit happens. You need a system that can cope with this properly.
I'm afraid a year from now netatmo will no longer exist, because they don't listen to their customers and we can go an buy something new. Without servers you couldn't even change the programs etc. Would be good that you could set the thermostat on the homeLan only, when disconnected to the server. In this respect Nest is a safer bet with google behind this.

Post Reply

Return to “Thermostat Network Set-up”