Netatmo Relay keeps disconnecting from servers

This forum provides technical help on how to set up Netatmo Thermostat Wifi connection.
Post Reply
SaschaR
Posts: 2
Joined: 23 Mar 2016, 14:30

Re: Netatmo Relay keeps disconnecting from servers

Post by SaschaR » 23 Mar 2016, 14:34

jfkm wrote: I wonder if among those affected by these disconnections, configure all HOMEKIT or not? It would help me to confirm or deny my track.
I can confirm your findings.
Had the disconnect roundabout twice a day and after 2 weeks the relais got completely stuck and had to remove the power.

Just after the last powercycle I removed the thermostat from my HomeKit Setup on my iPhone and guess what - not a single disconnect in the last 2,5 days! I didn't even had to reconfigure the thermostat for that.

Funny thing is that I already mentioned that to the support, if maybe the homekit integration might be the problem. Didn't react to that though...

S

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 24 Mar 2016, 06:48

Thx for you'r feedback ! For me, almost one week without Homekit, one week without déconnect...

Pete
Posts: 8
Joined: 12 Feb 2016, 19:38

Re: Netatmo Relay keeps disconnecting from servers

Post by Pete » 24 Mar 2016, 20:16

I was posting earlier in the thread and at the end of Jan was getting disconnected every night for a couple of weeks.

Have to say now that since my last post shortly after changing the channel to 11 my relay has been working fine and I can't remember when it last dropped out.

Quick edit - I do have the home kit settings enabled but am not making use of them at the moment.

nickfielibert
Posts: 10
Joined: 11 Feb 2016, 14:52

Re: Netatmo Relay keeps disconnecting from servers

Post by nickfielibert » 25 Mar 2016, 17:40

I think there is good news. I've seen we are now at firmware version 65 on the relay. I think they fixed the issue with disconnects, or rather the issue with the relay not automatically being able to re-connect after some network interruption for whatever reason. The past weeks after having done some analyses that I shared with netatmo support, I've not had any disconnects anymore, Also, when I force some network issue, the relay does reconnect without any problem. Not sure what the actual bug was and how it was fixed, but seems Ok now.
I have to say that it took some time, but they did respond to reports about the issues and contacted me about details.
After the negative comments here I wanted to post something positive :)

Would be interested to hear from the posters here if they now see the same (and perhaps check if you can see the FW version has changed to 65)? For me the case is closed and thank Netatmo support for the work done.

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 26 Mar 2016, 13:44

A update in 39/65 has just taken place on my relay / Thermostat.

So I just reconfigure HOMEKIT function to see if that solved the bug that disconnections.

I am now SURE,for me, it is the HOMEKIT function when it is in use that do the bug.

To follow in the day ...

It should quickly check cause before, when Homekit was not configured, no disconnections of the relay, and WHEN I connect HOMEKIT, disconnections in minutes / hours that followed ...

jfkm

lucadb
Posts: 2
Joined: 26 Mar 2016, 16:56

Re: Netatmo Relay keeps disconnecting from servers

Post by lucadb » 26 Mar 2016, 17:00

Hi everybody.
I'm still on 38/60 on all my five thermostats.
How do you force firmware upgrade?

Btw: with 38/60 and homekit not configured, had ZERO disconnections so far.

ricardolq
Posts: 5
Joined: 03 Jan 2016, 00:10

Re: Netatmo Relay keeps disconnecting from servers

Post by ricardolq » 26 Mar 2016, 23:53

Hi,

I've the same problem (long time ago) but I don't have the Homekit option in my android app (I guess homekit is an ios feature).

Also i've tried to upgrade the firmware just a few minutes ago, but rele stills remain at 60 version, 65 is not downloaded.

Changing wifi channels, using static ip assigned to relay mac address, and other options all you know neither work. I'm just able to force reconnection setting up again the wifi at netatmo relay :S

It would be great having any feed back from Netatmo about issue status

Good luck

ricardolq
Posts: 5
Joined: 03 Jan 2016, 00:10

Re: Netatmo Relay keeps disconnecting from servers

Post by ricardolq » 30 Mar 2016, 00:57

Brieuc_Netatmo, any news about this issue? My relay is currently disconnected from your servers, and kept disconnecting a lot of times last days.

ricardolq
Posts: 5
Joined: 03 Jan 2016, 00:10

Re: Netatmo Relay keeps disconnecting from servers

Post by ricardolq » 03 Apr 2016, 00:24

After contacting to Netatmo support, they commented that a bug related to this issue was solved at version 65 for relay. It's available since yesterday. I upgraded relay today and at this moment relay is still connected to servers, and I hope it will continue like that :)

Thanks

lucadb
Posts: 2
Joined: 26 Mar 2016, 16:56

Re: Netatmo Relay keeps disconnecting from servers

Post by lucadb » 03 Apr 2016, 00:28

How do you make the upgrade? Can't find "check for newer firmwares" on the app. Thanks.

Post Reply

Return to “Thermostat Network Set-up”