Netatmo Relay keeps disconnecting from servers

This forum provides technical help on how to set up Netatmo Thermostat Wifi connection.
Post Reply
Brieuc_Netatmo
Posts: 2954
Joined: 02 Jan 2014, 11:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Brieuc_Netatmo » 21 Jul 2016, 10:18

Hi Lezz,
Please try to disable HomeKit on your Thermostat, and let us know if you still have disconnections.
Brieuc - Netatmo Team

Lezz
Posts: 35
Joined: 27 Nov 2015, 10:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Lezz » 21 Jul 2016, 11:45

Will try that, but first I am giving the thermostat a static lease (permanent ip address) to see if that helps. I use homekit multiple times, every day, so I hope I don't have to disable this.

I think this has only been happening for me recently. I saw in the firmware post, that the versions are from May. I only saw this problem maybe once before June and I had to reboot the relay for it to fix itself and now the problem seems to happen very frequently. Maybe the latest firmware connection fix broke something else?

Can test on iOS 9.3.3 and iOS 10 public beta.

Lezz
Posts: 35
Joined: 27 Nov 2015, 10:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Lezz » 23 Jul 2016, 01:22

Static ip didn't work. Will try removing and adding to HomeKit again.

Lezz
Posts: 35
Joined: 27 Nov 2015, 10:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Lezz » 27 Jul 2016, 11:41

Removing and adding HomeKit again didn't help. Same bug. Removing HomeKit all together seems to fix the issue for now. No disconnect in the last 3 days.

Seeing as I bought this for the HomeKit support this is a real bummer. Did you guys identify what causes this issue?

jojost1
Posts: 11
Joined: 07 Sep 2016, 16:15

Re: Netatmo Relay keeps disconnecting from servers

Post by jojost1 » 10 Sep 2016, 12:49

Same problem here with 2 different thermostats in the same house, have them a few days and it NEVER worked for me. 1 hout at the time and then they will lose connection to their relais.

New Firmware
HomeKit Enabled
WiFi Channel 11

Please I want to have an official response to this issue, there have been no recent replies on this thread. Help us! I'm not the only one.

Lezz
Posts: 35
Joined: 27 Nov 2015, 10:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Lezz » 14 Sep 2016, 14:57

After a complete reset it worked for a few weeks but disconnect still happened with homekit enabled

nebelmeer
Posts: 7
Joined: 29 Dec 2015, 11:20

Re: Netatmo Relay keeps disconnecting from servers

Post by nebelmeer » 19 Sep 2016, 22:42

Lezz wrote:After a complete reset it worked for a few weeks but disconnect still happened with homekit enabled
Hello Lezz, sorry to bother you with questions, but you appear to be more competent than Netatmo's support..
I have the same excat problem, first noticed on august (but I don't check my iphone app regularly during summer of course), I'm on firmwares 68/40.
I always run the relays on dhcp reservation, wifi channel 11 on a Linksys X3500 gateway, and it all worked like a charm until few days ago. When the relays loose connection(I have 2 of them) they're still attached to my wifi network and I can ping them.
I tried to remove them from Homekit (from the netatmo app I deleted the whole home) to no avail, as today, after just one day, they disconncted again. I've now seen that there's another option in IOS Privacy/Homekit menu, so I disabled the Netmato app to communicate with homekit. Is this the correct procedure or is there anything more to be done? How do you hard-reset these relays anyway?

Lezz
Posts: 35
Joined: 27 Nov 2015, 10:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Lezz » 19 Sep 2016, 23:08

The fastest fix for me when it disconnects is o reboot my router. This always works for me as a temporary fix.

If you are on iOS 10 you can use the built in home app to remove the thermostat from HomeKit or you can download eve from the AppStore by elgato.

If I remember correctly the hard reset was holding the button on the relay for 30 seconds and then walk through the setup process.

Hope these problems get resolved soon.

drazick
Posts: 4
Joined: 27 Feb 2016, 00:43

Re: Netatmo Relay keeps disconnecting from servers

Post by drazick » 19 Sep 2016, 23:14

Same problem,my thermostat disconnected from server and nothing works,i reboot my router,configure wifi again and same results.

Whats happen?

crady
Posts: 8
Joined: 22 Jul 2016, 15:31

Re: Netatmo Relay keeps disconnecting from servers

Post by crady » 19 Sep 2016, 23:15

Hi there!

I have the same problem! My iPhone App tells me that my relay was removed from netatmo server - but Wifi an Internet is working as it sould. What can I do?

I don´t have a HomeKit Edition! So HomeKit should not be the problem I think...

Also I am not able to start the "normal" configuration using my iPhone... I have to plug the relay in to my Mac using the USB Cable...

What to do??? Help! Winter is comming!


EDIT: Also the App tells me that realtime mode ist not available and it will download settings every 10 minutes. It tells me thet my Firewall is blocking Port 25050 - I am not running a special firewall... and I did not change any setting in my router.

But setting arrive at my app (boiler off when opening the door e.g.) but are not sent to the relay / thermostat.

Also the radio connection between relay an thermostat became very poor the last days... always was good (nearly full - now just one sing - and sometimes loses connection :( batteries are 100%)

Post Reply

Return to “Thermostat Network Set-up”