Page 1 of 23

Netatmo Relay keeps disconnecting from servers

Posted: 07 Feb 2016, 17:28
by topazJ
About once a week remote access to our Netatmo thermostat stops working and the following is displayed:

Your Netatmo Relay is disconnected from our servers. Did you change the Wi-Fi password or turn off the Netatmo Relay? More help about this issue.

We haven't changed anything on our wifi!

Previously, after searching this forum, we have got it working again by logging on to our router and changing the channel - not sure why this works but it does!

Today before we realised it was disconnected, we heard some clicking noises coming from the thermostat and when we looked at it, it appeared to reboot or something? It's done this at least twice but it has not resolved the problem.

Before I go and change channel on the router again, I thought I would report the problem on here to see if anyone can help. It's not really acceptable that we should have to do this every week or so is it?

Also, if this happens when we are not at home, we wouldn't be able to do that. What's the point of a remote app that you can't use remotely?

Re: Netatmo Relay keeps disconnecting from servers

Posted: 07 Feb 2016, 19:04
by jmpeces
Good afternoon! I've since last January 19 with disconnections every 5 or 6 hours , and nobody solves anything. I talked to my internet company and everything OK , I opened ports, changed channels , etc etc etc and still not working.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 11 Feb 2016, 15:29
by nickfielibert
I have the same problem with one of my 2 thermostats. The weird thing is that they are both connected to different AP´s but both of the same type. One never experiences a problem, while the other does. You would think an issue with the thermostat. However, I can fix the problem by restarting my home router where it´s DHCP server then gives an IP address to the thermostat. The weird thing is that it gives a different IP address to the thermostat. This is strange because normally in the DHCP offer, the DHCP server will give the same IP address that the device g°had before, because the MAC address hasn´t changed. The only reason another IP address would be given is that it thinks it is a different device, or the address is already given to another device. Obviously, this isn´t the case (I´ve got a Netatmo server disconnect from IP address, after restarting the router, it is, no other devices have So t seems there is something wrong in with DHCP handling in the Netatmo relay. Both my Netatmo relays, as well as the thermostats have the same FW (version 60 and 38 respectively). Both wifi signal receptions are strong, the AP´s are on non overlapping frequencies or at levels 30 to 40 dB apart so no interference can occur. The last thing I plan to try is a fixed IP address for the relay that has this problem. The issue I have is that my router (from my SP) does not allow me to reserve IP addresses, so would need to do this on the relay. t seems I can only do this by connecting the relay to the PC via USB. I did get a message during one of the attempts to reconnect at home that I could try again or enter manual config, but unfortunately tried again an then the relay was able to reconnect to my wifi AP.
By the way, I do see the 2 relays in my connected devices list with the correct AC address.
I think the issue is that the router decides at some point to renew the lease and during that sequence something goes wrong on one of the relays. I would have shipped the relay back, but see that many have the same issue. From Netatmo support I received a mail from Pablo with some tips and one of these was to enter the fixed IP address. I think this is a SW issue, but don´t understand why it is then different on my 2 relays.
Question1: is there a way, while only being being connected wireless to change to network setting (set to fixed IP address)?
Question 2: needs a fix. I´m a network expert (I work for Cisco :-)), but most people aren´t so can imagine this is bad for your product.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 12 Feb 2016, 12:22
by tipoldo
I have the same problem. Occasionally the thermostat lost the internet connection, and the only way I have to fix it, is restarting the thermostat. On the same WIFI I have a netatmo wheather station, but this product does not present any issues. I suspect too that it is firmware issue, and they have to fix it.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 12 Feb 2016, 20:38
by Pete
I am glad this is not just me. I was thinking of returning the item as faulty/unfit for purpose but if a few people are affected it seems like a firmware problem which should be resolvable.

My thermostat was first set up on 29th Dec and ran without a single problem until 25th Jan.

Since then it has been losing its connection just about every day. Some days if I reboot it, the graphs will then update to show the temperatures but other days like today - the data is missing so the graph just fills in a straight line from the last recorded data point to the time of the reboot. Most annoyingly the prediction feature of the thermostat no longer works so the house is much colder in the mornings than when the thermostat was turning the boiler on early to compensate for bad weather.

I have tried moving repositioning the access point to rule out signal strength as the problem. The access point (Apple Airport Extreme) currently shows signal quality is "excellent" and gives RSSI of 66dBm for the relay which I think is medium to good signal strength. No other devices in the house are having problems with networking. DHCP is coming from a Cisco router as the access point is only used as a bridge.

Netatmo support - if you can see my relay the serial no is j0a801c . Hoping you might be able to access it and see any clues to what is causing the problem.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 12 Feb 2016, 22:58
by Pete
Checking the DHCP leases on my router shows something which may be significant. All clients except the Netatmo relay have 01 prepended to the mac address. The other clients are a mix of Macs, Windows , IOS devices, TV boxes etc. Here is the output from the Cisco 12.4 router...

C1841_Internet# sh ip dhcp bind
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name 0100.xxxx.9a94.d9 Feb 13 2016 05:41 PM Automatic 01cc.xxxx.2d58.fb Feb 13 2016 08:22 PM Automatic 0108.xxxx.9e05.0c Feb 13 2016 09:26 PM Automatic 0100.xxxx.8ffc.16 Feb 13 2016 06:00 PM Automatic 0100.xxxx.7ffa.e9 Feb 13 2016 06:00 PM Automatic 017c.xxxx.6cbd.27 Feb 13 2016 02:51 PM Automatic 016c.xxxx.00cf.52 Feb 13 2016 07:33 PM Automatic 70ee.500a.7556 Feb 13 2016 09:18 PM Automatic <--- This is the Netatmo relay 0100.xxxx.adf2.66 Feb 13 2016 05:45 PM Automatic 014c.xxxx.374c.db Feb 13 2016 08:47 PM Automatic 0100.xxxx.41f5.b8 Feb 13 2016 09:00 PM Automatic 0100.xxxx.dc71.86 Feb 13 2016 08:55 PM Automatic

I understand that the DHCP Client identifier is made up of a hardware type (01 for ethernet) and the client hardware address (i.e. the mac address). Also I believe sending the Client identifier (DHCP Option 61) is optional. It looks like Netatmo may be omitting this parameter unlike the other hosts on my network. Perhaps this behaviour is causing the problems with DHCP lease renewal on certain routers.

Unfortunately at home I cannot easily capture the packets on the network with Wireshark to see exactly what is in the DHCP request but I can run a "debug ip dhcp server" command on the router while the relay is rebooting and get the following.

*Feb 12 21:18:12.873: DHCPD: Sending notification of DISCOVER:
*Feb 12 21:18:12.873: DHCPD: htype 1 chaddr 70ee.500a.7556
*Feb 12 21:18:12.873: DHCPD: remote id 020a0000c0a8010101000000
*Feb 12 21:18:12.873: DHCPD: circuit id 00000000
*Feb 12 21:18:12.873: DHCPD: DHCPDISCOVER received from client 70ee.500a.7556 on interface FastEthernet0/1.
*Feb 12 21:18:12.873: DHCPD: Seeing if there is an internally specified pool class:
*Feb 12 21:18:12.873: DHCPD: htype 1 chaddr 70ee.500a.7556
*Feb 12 21:18:12.873: DHCPD: remote id 020a0000c0a8010101000000
*Feb 12 21:18:12.873: DHCPD: circuit id 00000000
*Feb 12 21:18:12.873: DHCPD: Sending DHCPOFFER to client 70ee.500a.7556 (
*Feb 12 21:18:12.873: DHCPD: creating ARP entry (, 70ee.500a.7556).
*Feb 12 21:18:12.873: DHCPD: unicasting BOOTREPLY to client 70ee.500a.7556 (
*Feb 12 21:18:12.929: DHCPD: DHCPREQUEST received from client 70ee.500a.7556.
*Feb 12 21:18:12.929: DHCPD: Sending notification of ASSIGNMENT:
*Feb 12 21:18:12.929: DHCPD: address mask
*Feb 12 21:18:12.929: DHCPD: htype 1 chaddr 70ee.500a.7556
*Feb 12 21:18:12.929: DHCPD: lease time remaining (secs) = 86400
*Feb 12 21:18:12.929: DHCPD: Appending system default domain
*Feb 12 21:18:12.933: DHCPD: Using hostname '' for dynamic update (from hostname option)
*Feb 12 21:18:12.933: DHCPD: Sending DHCPACK to client 70ee.500a.7556 (
*Feb 12 21:18:12.933: DHCPD: creating ARP entry (, 70ee.500a.7556).
*Feb 12 21:18:12.933: DHCPD: unicasting BOOTREPLY to client 70ee.500a.7556 (

Re: Netatmo Relay keeps disconnecting from servers

Posted: 13 Feb 2016, 11:05
by Pete
This morning as usual my relay is disconnected again from the servers.

I checked the logs on the DHCP server and the Netatmo has not tried to renew it's lease at all. Normally I would expect it to try after half of the lease time has expired which would be 12 hours with the Cisco default time of one day. Other devices were updating leases fine overnight or when powered on. As I rebooted the relay about 9pm last night was expecting a renewal request at 9am this morning. However it seems the connectivity was lost well before then or prediction mode would have fired up my boiler early as it is a cold morning today.

Could not ping the relay either so it has lost local network connectivity not just to Netatmos servers.

Rebooted the relay and it is back again on the same IP as before and reachable again by the servers.

Will be doing some more tests today so will report back later with any more findings.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 13 Feb 2016, 18:51
by nickfielibert
I thought I had founf the problem comparing settings in my 2 access points (same WAP300N as mentioned in my earlier post). The only difference I could find was the security setting. Unfortunately, during the morning the server got disconnect from the relay that usualy has the problem. Strangely so, I found that I could still ping the relay in my home network (IP address assigned by my telenet home gateway). This time instead od rebooting the router I just rebooted the Wireless AP, and connection with the netatmo server was restored. If I have the problem again, I'll just will disconnect and reconnect the RJ 45 plug for this AP. I bet it will work again afterwards. So, connectivity in the homenetwork remains in tact, but the server can't reach the relay. Needs further thought and would like to understand from Netatmo, how their server makes connection with the relay, through the gateway firewall.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 13 Feb 2016, 20:31
by Pete
This morning I set DHCP lease time to four hours.

The Netatmo relay has been renewing its lease every two hours as you would expect. I can see the renewal being logged on the router and so far there has been no problem and the relay is still online.

I am running a timed ping to the relay to see if I can see when communication stops. I guess I just leave it running overnight and hope I don't forget and shutdown the laptop while it is logging the pings.

I can see from the NAT translations the relay has a connection open on port 25050 to which is one of Netatmo's servers. On my system incoming connections are blocked so the relay would have had to open this connection from my side of the router. Once this connection is established then Netatmo can send commands to the relay.

Next time it goes I'll see what happens by disconnecting my AP first rather than rebooting the relay as usual. My gut feeling is that nothing will happen as the relay has lost connection to the network so won't notice the AP has reconnected/rebooted.

Re: Netatmo Relay keeps disconnecting from servers

Posted: 14 Feb 2016, 12:31
by Pete
Once again the thermostat was disconnected from the servers this morning.

Could not ping the relay and restarting the access point had no effect. Other devices reassociated to the network and renewed their dhcp leases but no packets seen from the relay until I rebooted it.

When I looked at the log file I was recording on the laptop I can see that the ping to the relay were working fine until about 02:25 this morning. Until this there is the odd missed ping but the vast majority are coming back. At 02:25 things start to slow down with some of the pings taking over 100 seconds ( 100000 ms ) to return and a many pings lost. The very last ping returned is at 02:37 and every after that times out. One more thing I noticed is throughout the day while relay working fine the response times vary from around 3ms to over 1000ms. Now that could be network problems especially over wireless but from now I am running a similar trace from my laptop to the main router as a control.

I no longer think dhcp is responsible for this behaviour as the loss of network happened about 30 mins after the relay last renewed its lease and 1hr 30 before it was due to renew.

The relay is not completely dead as it is still communicating with the thermostat and uploads the temperature readings to the internet once connection resumed. I guess it only has a buffer to hold around 12 hours data thought as if I don't restart it until the evening the data points only show up to mid afternoon.

So this morning I have put the router back to its original settings of 24 hour leases and make a change elsewhere.

The change I have made for today is changing the access point channel number from ch1 which was auto assigned to channel 11 as has been suggested elsewhere in the forum. Lets see what difference if any that makes.