Page 1 of 1

Relay not responding

Posted: 18 Nov 2017, 17:05
by spk7
Hi all.
This morning i woke up and found the app saying "no connection". After a quick check I found that the relay is not working properly. I tried to reset it but the phisical button does not work, even after pressing for more than 15".
Now everything is stopped: the thermostat can't be setted with programs, the valves too, the house is cold and the only solution is to disinstall valves and use maually the thermostat without programming.
I wrote to the netatmo support but of course they are not responding quickly and they have no online / phone support.
I am very disappointed because I also found that the relay is not sold separately so (if it is broken) I must buy a new thermostat (warranty is over I guess, must check).
Please note that the port is properly open in my router (it worked since yesterday) and the relay flashes 5 times when connected at the power but after that.... nothing.
Now I have some questions for u all, so u can help me:
1- is it true that the relay is not sold separately?
2- if the phisical button is not responding, do u think it's broken?
3- is there something I could do to try to solve this problem?
4- anyone haad this kind of issue before?

Thank u in advance if u can help me.
Regards-

Re: Relay not responding

Posted: 25 Nov 2017, 11:18
by spk7
OK I see that Netatmo support is null. Nobody answer via email nor here. I decided to change completely my heating system switching to another company.
I will try to sell my valves that are working finem while the thermostat (and all the system) works only with a new relay.
If someone is interested just contact me.
Goodbye Netatmo.

Re: Relay not responding

Posted: 04 Dec 2017, 15:53
by anamu
The same this has happened to me. The relay went unresponsive on 27th Nov. I called Netatmo Support (Help Link) who were absolutely useless. They did mention it had happened to a few clients, but offer no solution or explanation. The customer service is disappointing to say the least

I've managed to get a replacement from Amazon, and that seems to be working half well (boiler - relay - thermostat connection working, but app is not linking properly)

Re: Relay not responding

Posted: 05 Dec 2017, 11:48
by jjgracia
The same has happened to me.

Re: Relay not responding

Posted: 02 Feb 2018, 20:07
by Oblong31
Same happened to me late last night after 34 hours after installation so hopefully covered by some sort of warranty. It was installed as a first time thermostat and I was pleased with it. This morning disconnected the relay from boiler and plugged it into the mains with the 3 pin power plug that came with it. When relay plugged in no lights come on and no amount of holding the button causes a light to come on. This confirms the fault is in the relay unit. It worked properly for 34 hours so defenitly not an installation problem. Netatmos not responding to my reporting this through their web site. Will give it another 18 hours then start the return/replace process with Amazon.