Connected/disconnected/connected… ad nauseam

Tips, tricks and frequently asked questions
AngeloM
Posts: 1
Joined: 16 Feb 2021, 10:32

Re: Connected/disconnected/connected… ad nauseam

Post by AngeloM »

I can only join this thread with my problem...

I would say it is definitely a camera problem. SW or maybe in the chipset. I bought 2 of them like mid 2020. One works perfectly from day one. it is closer to both router and repeater. One is only a few metersand a wall away and faces the courtyard, so it might also be nearer to neighbour's wifis. That one is constantly disconnecting.

Disconnection happen randomly but a number of times every day. Last anything from minutes to hours

Support says it is because of mesh (Fritzbox). I removed the repeater from the mesh, gave him his own SSID name. Tried just about everything else including buying a newer repeater (the previous one was not hold however). Nothing.

Both cameras are on 198

I think maybe the chipset or sw looks for new networks and gets caught in that. I just dont get why, why would anybody want a security camera to scan for new networks ? It is unconceivable for a security product. It should stick with his network and be strongly protected.

I could try moving the repeater a bit closer so the signal is much stronger than any other possible competing wifis, but I dont want to do this since that would mean moving to our bedroom... a repeater there is a nogo

Pity actually, I wish support would finally do something about it....

A
david79nl
Posts: 22
Joined: 19 Mar 2018, 10:39

Re: Connected/disconnected/connected… ad nauseam

Post by david79nl »

The two Presence camera's have been reasonably stable for the last year but this sunday one of them started to disconnect sometimes for hours. Sometimes i am still able to see the live stream in HomeKit and most of the time the IP address of the camera will respond to pings for a while longer.
It usually comes back by itself after either minutes or hours ....

It would be great if the camera had an accessible log somewhere....
Lpope
Posts: 54
Joined: 04 Jul 2020, 21:58

Re: Connected/disconnected/connected… ad nauseam

Post by Lpope »

I know this is an old thread but I’m having exactly the same issue. 2x out door cameras started to disconnect regularly and the indoor one too.
But the doorbell is very stable and is further away from the Wifi point than the indoor camera.
All have up to date firnware.
thealbs
Posts: 10
Joined: 28 Apr 2021, 13:39

Re: Connected/disconnected/connected… ad nauseam

Post by thealbs »

I installed a third Presence today and am getting the same issues on the new camera. I have two others (with Siren) that have been fine for several months.

The new one m(no siren) keeps disconnecting. originally it said it was an SD Card issue (I reseted the card) and now it just refuses to respond to anything at all. No errors in the log, nothing. Its just offline.

Is there a way to reboot these??
Mutant_Tractor
Posts: 3
Joined: 04 Jun 2021, 12:34

Re: Connected/disconnected/connected… ad nauseam

Post by Mutant_Tractor »

TL;DR: Unplug all your HomePods to force a hardwired device like an Apple TV to become HomeKit master - the problem is not with the Netatmo camera or wifi connection to the camera, instead it's the wifi connection to your HomeKit master node, which can sometimes be on HomePods with spotty Wifi.

Signed up just to say I was experiencing this and the disconnections seemed to just come randomly out of nowhere.

I knew it wasn't the Wifi as the signal strength is perfect - 100% and I have a very large Ubiquiti UniFi deployment, and an AP hardwired right next to the camera, all the stats from the AP looked good and there were actually no Wifi disconnections at all, even though the camera was flip-flopping on and off every 2-3 minutes, so that ruled that out.

I had a hunch it might be that the "wrong" device was my HomeKit Hub controller - given HomeKit doesn't choose the best one for the job, i'm not sure how it's selection method works but when I checked it my Kitchen HomePod was showing as "connected" meaning it was the HomeKit master - we've had problems with it's wifi going on and off randomly.

So I unplugged all my HomePods to force HomeKit to elect the hardwired Apple TV as master which it did after about 5 minutes.

Since then, absolutely zero drops - HKSV rock solid and streaming doesn't blips at all.
thealbs
Posts: 10
Joined: 28 Apr 2021, 13:39

Re: Connected/disconnected/connected… ad nauseam

Post by thealbs »

In my case it seems to have been a defective SD card. New card and some silicon lube and its stopped panicking for long enough for me to think that was the root cause.
Mutant_Tractor
Posts: 3
Joined: 04 Jun 2021, 12:34

Re: Connected/disconnected/connected… ad nauseam

Post by Mutant_Tractor »

Update on mine - errors are back as soon as homepods get plugged in, very weird.

Gonna try the SD card swap and see if that resolves it.
Mutant_Tractor
Posts: 3
Joined: 04 Jun 2021, 12:34

Re: Connected/disconnected/connected… ad nauseam

Post by Mutant_Tractor »

Another update, I changed the wifi network the camera was connected to, to enable UAPSD and changed the cameras name, as I had read about old names causing problems with HomeKit and additionally factory reset all my homepods- that combo seems to have fixed the problem.
Post Reply

Return to “General questions”