API not working properly

The Netatmo API is a set of webservices allowing developers and third parties to access Netatmo device's data.
Post Reply
fox91
Posts: 3
Joined: 03 Jun 2019, 10:21

API not working properly

Post by fox91 »

Hi,
I'm using getpublicdata method to get data from stations around my home and some other places in Italy.
From 16:45 on 28/05/2019 I am receiving this error many times:

Code: Select all

"failed to connect to server [localhost:27020] on first connect [MongoError: connect ECONNREFUSED 127.0.0.1:27020]"
This clearly indicates some problem in your MongoDB cluster.
I thought it was one of the many temporary errors but it is continuing even now.

Can you kindly check it out?

Thanks
Andrea
andy333
Posts: 7
Joined: 20 Nov 2018, 16:54

Re: API not working properly

Post by andy333 »

I'm also getting errors. No data receiving on API.
andy333
Posts: 7
Joined: 20 Nov 2018, 16:54

Re: API not working properly

Post by andy333 »

More precisely, I no longer get "dashboard_data" from the API in the "modules" array in PHP.
fox91
Posts: 3
Joined: 03 Jun 2019, 10:21

Re: API not working properly

Post by fox91 »

fox91 wrote: 03 Jun 2019, 10:33 Hi,
I'm using getpublicdata method to get data from stations around my home and some other places in Italy.
From 16:45 on 28/05/2019 I am receiving this error many times:

Code: Select all

"failed to connect to server [localhost:27020] on first connect [MongoError: connect ECONNREFUSED 127.0.0.1:27020]"
This clearly indicates some problem in your MongoDB cluster.
I thought it was one of the many temporary errors but it is continuing even now.

Can you kindly check it out?

Thanks
Andrea
From 09/23/2019 I'm getting this error again!
The situation is unchanged from 09/23 to today.

I do not see updates in the status pages (https://status.netatmo.com/) to report a recent problem, indeed: it seems abandoned.
Daegil_Netatmo
Posts: 17
Joined: 18 Jul 2019, 09:51

Re: API not working properly

Post by Daegil_Netatmo »

Hi!

If you encounter difficulties with the API, please contact the support with the detailed endpoints and calls you are using. I would advise that you send it under a postman format to make the diagnostic faster and clearer.

Have a nive day! :)
fox91
Posts: 3
Joined: 03 Jun 2019, 10:21

Re: API not working properly

Post by fox91 »

Daegil_Netatmo wrote: 01 Oct 2019, 15:12 Hi!

If you encounter difficulties with the API, please contact the support with the detailed endpoints and calls you are using. I would advise that you send it under a postman format to make the diagnostic faster and clearer.

Have a nive day! :)
Hi Daegil,
how can I reach the support? I think that this forum is the only way.

It seems that tonight the error was resolved, it was in error from 23/09, good job!
Daegil_Netatmo
Posts: 17
Joined: 18 Jul 2019, 09:51

Re: API not working properly

Post by Daegil_Netatmo »

Hi!

When you have a question or issue, you go to our help center: https://helpcenter.netatmo.com/en-us
You will find related subjects there, faq, and also a link to contact the support if the website doesn't answer your question. This would also help the support by giving them a hint of what you are looking for.
As we have several theme (security, weather, energy) this will also automatically send you to the correct support team.

Have a great day!
Post Reply

Return to “Netatmo API”