Page 1 of 1

Problematic Radiator Valve

Posted: 14 Jan 2019, 13:06
by kpc
Hi all.

Recently bought one radiator valve in addition to my Netatmo thermostat. And really started to hate it after few week usage.

The valve got updated to latest firmware v.73.

Problems
1) the valve shows around +3 degrees than there is in the room, so I have to set the True temperature. But if i set the true temperature it often gets stuck on this temperature. ( valve shows 19 degrees, but in reality the room is already 23 degrees hot)
2) very often I get the error in app (!) that the valve is not accessible and the ! mark on the valve.
3) less often there is error that valve cannot be calibrated.
4) less often - for example - thermostat temp 21 room temp 23.5 valve temp 19 room temp 20. but still the boiler keeps heating and I have to set away mode, then cancel away mode, and the boiler turns off.

the 2,3 can be fixed by restarting the valve, but after each restart I have to reset the True temperature of the valve.

This all leads that I have to restart the valve every day, otherwise there will be sauna in the house.

Does Netatmo valves and thermostat run stable for everyone, or its just me with these gliches?

Netatmo thermostat standalone was working fine, so wanted to upgrade all radiators with valves, now I regret that chose netatmo over Dandoss :(

Re: Problematic Radiator Valve

Posted: 15 Jan 2019, 20:26
by Gresteh
The valves are somewhat glitchy, but the least you touch them the better.

In my experience leave them alone for a few days to see if it makes any difference, the room may become a sauna or a freezer for a few days, but eventually it should work. In my opinion the least you fiddle with your valves the better. True temperature should only be used once the temperature has been stable for a while... and then leave it alone for a few days. After airing your rooms, the temperatures will be off again but don't touch the true temperature setting even if the temperature is wrong, leave it alone, after a few hours it should work as intended once again.

After using 3 valves for a couple of months I’ve found that the least your fiddle with them the better they work. I've just installed 5 extra valves for the rest of my radiators and I don't intend to touch them until everything is stable... the rooms may become overheated or too cold for one or two days but if you don’t touch your valves the temperature will work as intended (provided that you adjust the true temperature setting only when the temperature is stable and don't fiddle too much with it).If you set the true temperature setting do it slowly, one degree at most ever few days, remember, one degree once the temperature is stable and leave it for a few days, then repeat that process until your temperature is right, and leave it be.

As for the exclamation mark in your valve, try to move your relay to another place to maximize coverage.

Re: Problematic Radiator Valve

Posted: 11 Feb 2019, 16:01
by SPopenko
Looks like I have the similar issue. Also bought the third valve and use three of them in the single room. After an attempt to add it everything is broken. All of them show "!" and stop being reachable in the app.

Do you find any recommendations on what to do with this?