Netatmo Relay keeps disconnecting from servers

This forum provides technical help on how to set up Netatmo Thermostat Wifi connection.
topazJ
Posts: 3
Joined: 17 Jan 2016, 21:13

Re: Netatmo Relay keeps disconnecting from servers

Post by topazJ » 08 Mar 2016, 18:03

Netatmo it is not acceptable to expect users to tweek router settings just to get your product to re-connect itself to your servers! This is something that should be automatically handled just like every other wifi connected gadget that I own does without me even noticing. A lot of people I know would not have a clue how to change settings on a router and really, why should they need to know that?

Is there any ETA for the fix that you talk about?

NotatGo
Posts: 5
Joined: 04 Mar 2016, 18:44

Re: Netatmo Relay keeps disconnecting from servers

Post by NotatGo » 08 Mar 2016, 19:47

Have been contacted yesterday by Netatmo after my cry for help during the weekend through their contact system. They advised me to change wifi channel (on 6 now) and I reconnected the wifi yesterday evening and it seems to work (already for 24h), but I agree with the previous post, and I also told them in my reply mail, that it is not normal that we have to do these manipulations to get connected again....awaiting for final solution and communication about it from Netatmo...

Perchance
Posts: 1
Joined: 12 Mar 2016, 11:29

Re: Netatmo disconnecting from servers - solution Update

Post by Perchance » 12 Mar 2016, 11:51

This is an update to the post below. As an experiment, I switched my router channel from 11 to 6 for the reasons given below. I have continued to have no disconnection for two weeks. Maybe the bug has now been fixed. However, it also occurs to me that having the router channel set to 'automatic' could be a reason why the connection drops and will not reconnect as the channel number could be changing periodically. So if anyone is still experiencing this issue it's worth trying fixing the router channel to a specific number. It seems to have worked for me.


I have had the same problem of regular disconnection every few hours from the Netatmo servers and having to reset the thermostat each time. A real pain!

I have solved (so far!) it by changing my router to channel 11. It has now not disconnected for over a week.

It is however inconvenient because channel 11 is the most used locally, so my speed is affected for all my other wifi usage.

Can Netatmo explain why this fix works? If using channel 11 is necessary, why is it not not specified in the setup information? Is there another channel that can be used? Can Netatmo fix this bug in a firmware update?

Please could a Netatmo representative reply to these points.
Last edited by Perchance on 21 Mar 2016, 10:40, edited 1 time in total.

Brieuc_Netatmo
Posts: 2936
Joined: 02 Jan 2014, 11:20

Re: Netatmo Relay keeps disconnecting from servers

Post by Brieuc_Netatmo » 14 Mar 2016, 18:00

Hello everyone,
Thank you all for your feedback, we've finally spotted a bug which could cause these disconnection issues.
We're doing our best to solve it as soon as possible, a new firmware will be released soon.
Thank you again for your patience.
In the meantime, please select channel 11 if you ever encounter such problem.
Brieuc - Netatmo Team

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 17 Mar 2016, 17:38

(SORRY !! GOOGLE TRANSLATE...)


It SEEMS to me to have found a track ...

I'm not sure of my shot, but if it can eventually help engineers Netatmo of this worries visibly NOT anecdotal or isolated disconnections relay ...

So after switching from channel 6 to channel 11 of the box, not the best for me.

Yesterday, still disconnections xxxx ...

Last night, tired and almost by habit now, I pull over.

I reconnect, and I raise the wifi configuration (via iPhone apllication).

BUT .... one thing I do differently compared to my habits: I DO NOT HOMEKIT RECONFIGURE. Just to see ...

And today, at the time you or I wrote (5:31 p.m.), no disconnections since 6:00 this morning ...

Hazard ? Cause and effect? I know absolutely nothing, but I share in case.

Now if some are bothered by disconnections when their thermostat is not compatible Homekit, or it does not configure the My Hypothesis does not hold.

A word;)

mattgallon
Posts: 10
Joined: 11 Mar 2016, 17:58

Re: Netatmo Relay keeps disconnecting from servers

Post by mattgallon » 18 Mar 2016, 09:19

A weeks since my posting on here and no replies (sigh). I eventually heard back from Netatmo with the suggestion that I switch to channel 11 - already done, no effect.
The unit has disconnected twice more in the last 7 days and the only fix is cycling the power. I'm away from home now for a few days, so if it disconnects while I'm away, I'l be returning to a cold house.

The support email admitted this was a known bug "which was being worked on". To my mind, the company are therefore continuing to sell a product which doesn't work reliably so should be providing those of us affected with more information about when the fix is likely to be available. I'm heading over to Twitter and Amazon to vent my frustration (having previously reviewed the thermostat very positively until this problem arose) about the problem and the limited response - I suggest you do the same and perhaps Netatmo will get their fingers out.

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 18 Mar 2016, 18:38

2nd day without disconnecting ...

I have not changed anything EXCEPT the fact of not activate HOMEKIT ...

Netatmo gentlemen, if that helps ...

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 19 Mar 2016, 12:27

I continue my investigations ... Me feel a little lonely, but it does not matter !!

I'm not an engineer, but I try to understand, through tests at home, it happens.

For about a month, so regular disconnections thermostat, with the obligation to put everything on the way each time.

Changing the channel box, on 6 and 11: no improvement.

There are 3 days during a relocation following new disconnection (always on channel 11), I decided, for the FIRST time, not to reconfigure HOMEKIT.

And the notorious CHANGE: not disconnected for 3 days ...

This morning I RECONFIGURE homekit.


And bim! Re-disconnection in few minutes ...

I just restart the installation without HOMEKIT, and I will again test.

I wonder if among those affected by these disconnections, configure all HOMEKIT or not? It would help me to confirm or deny my track.

Thank you :)

jmpeces
Posts: 16
Joined: 22 Jan 2016, 17:12

Re: Netatmo Relay keeps disconnecting from servers

Post by jmpeces » 19 Mar 2016, 16:13

jfkm wrote:I continue my investigations ... Me feel a little lonely, but it does not matter !!

I'm not an engineer, but I try to understand, through tests at home, it happens.

For about a month, so regular disconnections thermostat, with the obligation to put everything on the way each time.

Changing the channel box, on 6 and 11: no improvement.

There are 3 days during a relocation following new disconnection (always on channel 11), I decided, for the FIRST time, not to reconfigure HOMEKIT.

And the notorious CHANGE: not disconnected for 3 days ...

This morning I RECONFIGURE homekit.


And bim! Re-disconnection in few minutes ...

I just restart the installation without HOMEKIT, and I will again test.

I wonder if among those affected by these disconnections, configure all HOMEKIT or not? It would help me to confirm or deny my track.

Thank you :)
Good afternoon! What do you mean Homekit ? That way you deactivate ?

jfkm
Posts: 110
Joined: 24 Nov 2015, 17:40

Re: Netatmo Relay keeps disconnecting from servers

Post by jfkm » 19 Mar 2016, 19:19

IMG_0147.PNG
IMG_0147.PNG (79.88 KiB) Viewed 388 times
Homekit, for Apple device.

Post Reply

Return to “Thermostat Network Set-up”